Zavřít reklamu

Vývojář Max Kellermann objevil zásadní bezpečnostní chybu v linuxovém jádře 5.8. Podle jeho zjištění tato chyba postihuje i pozdější jeho verze. Vulnerabilita, jíž dal vývojář název Dirty Pipe, se týká všech zařízení s operačním systémem závisejícím na linuxovém jádře, jako jsou právě androidové smartphony a tablety, chytré reproduktory Google Home nebo chromebooky. Chyba umožňuje škodlivé aplikaci zobrazit veškeré soubory na uživatelově zařízení bez jeho předchozího souhlasu, především však dává hackerům možnost spustit třeba na jeho smartphonu nebo tabletu škodlivý kód a tím nad ním převzít kontrolu.

Podle redaktora webu Ars Technica Rona Amadea je počet androidových zařízení postižených touto zranitelností velmi malý. Je to proto, že většina telefonů a tabletů s Androidem se spoléhá na starší verzi linuxového jádra. Jak zjistil, chyba se týká pouze smartphonů uvedených na trh s Androidem 12. Mezi nimi je například Pixel 6/ 6 Pro, Oppo Find X5, Realme 9 Pro+, ale i řada Samsung Galaxy S22 a telefon Galaxy S21 FE.

Nejjednodušším způsobem, jak zjistit, jestli je vaše zařízení chybou ohroženo, je podívat se na verzi jeho linuxového jádra. To učiníte otevřením Nastavení -> O telefonu -> Verze systému Android -> Verze jádra. Dobrou zprávou je, že zatím nic nenasvědčuje tomu, že by hackeři zranitelnost zneužili. Po upozornění vývojářem vydal Google patch, který má postižená zařízení před chybou chránit. Podle všeho se však zatím ke všem zařízením, kterých se to týká, nedostal.

Související články

Dnes nejčtenější

.